Endoscope-3 Slow Frame Rate

Questions on installation, device drivers and video application.
Post Reply
StewD
Posts: 10
Joined: Mon Jul 13, 2015 2:31 pm

Endoscope-3 Slow Frame Rate

Post by StewD » Thu Jan 19, 2017 9:14 am

The Endoscope-3 is a USB2 High Speed (480 Mb/s) device, with an Omnivision OV9665 sensor, and an unknown micro-controller handling USB communications.

The OV9665 sensor is set to auto adjust the exposure time for the available light on the target. This can be seen when the video Preview is stopped and restarted: the displayed image brightness comes up in 3-5 steps then stabilizes.

The OV9665 sensor needs a long exposure time or strong illumination to acquire an image with good brightness and contrast. With normal inside
ambient light levels, this results in an exposure time that limits the maximum frame rate that can be delivered. Conversely, if the light level is
increased, such as with an external source, the exposure time goes down and hence the frame rate increases.

Our tests here show the following:
1. In 640x480 mode, normal ambient, the display app reports 15 fps. With increased light levels, this increases to 28-30 fps.

2. In 1280x1024 mode, normal ambient, the display app reports 4 fps. With increased light levels, this increases to 6-7 fps.

We recommend that capturing images and video clips be done with an external light source. We have had excellent results using one of the new LED lamps: low power and very white light output.

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests